Proggio’s new look is brilliant!

A new Project Portfolio interface:

Before making that one small step into our new user interface, here’s a short guide to make your transition smoother.

From anywhere in the tool, you will find a red button located in the top toolbar, letting you access Proggio’s new look. Clicking that button will automatically redirect you into a revamped interface of the Project Portfolio.

The new Project Portfolio page incorporates in it the formerly known ‘All Projects’ page, allowing you to easily switch views to manage different aspects of the information. In other words, you are always able to look at the same information from a different angle.

For example, Project portfolio timeline is a high level view, like a slide. It is designed to visually present a portfolio status. In some cases, you may require additional information, which is better presented with a table. This is why we have enabled a new dropdown menu allowing a quick toggle of the displayed information in the following different modes:

Map:

Displays your Portfolio of active projects over a timeline. Showing you where each project is planned to begin / end, while giving you a reference line of today’s current date. It allows you to drill one level down into a single project’s timeline, which pops up in the splitscreen section, by clicking once on a single project timeline. While it is possible to make changes or report progress to a project timeline through the split screen, it is preferred to navigate into the Project Map timeline for more advanced features.

By default, projects are displayed in ‘Milestone View’, distributing your major project milestones in their chronological order, giving you a high-level visual representation.

Click the ‘Eye’ icon on the top right side to customize the level of detail you would like to see. For example, switch from Milestone View to a predefined Dynamic View of your Portfolio.

Cards:

Displays your projects in groups of ‘Active’, ‘Templates’, ‘Sub-Projects’ and ‘Archived projects’. The project information shown on each card is minimal as the main purpose of using this mode is the  quick access into your workspace’s Active projects.

Click the 3 dots menu from the right top corner of each card for quick access to relevant project options such as its settings or other administrative actions. Alternatively, right clicking the project card will access the same menu.

Board:

Displays your projects over a kanban-like board. This view mode allows you to categorize your projects by their lifecycle stage and sort them by various sort criteria.

Click the ‘Sort by’ menu to reorder projects in each swimlane according to your preferred criteria. Example: Sort by project Rank or Priority to push such projects to the top of each lane (also called ‘Workflow Stage’) 

List:

Displays a list of all your active projects in a spreadsheet like list. The list allows you to add metadata fields relevant for high level management of projects. You can organize the columns exactly the way you want them, to show just the right amount of information at any given time.

Click the ‘Eye’ icon on the top right side to “Edit columns of the displayed list. Add the Rank column along with the business driver columns in order to initiate the Auto Ranking feature (Available on select subscription plans)

A new Project Map interface for all your planning and execution needs!

From the Portfolio page, in Map mode, click the project name or double click on a single project timeline to open a single project map view. Alternatively, you can access a Project Map timeline from any other display → Cards, Board or List. Working in project map view, allows you to make updates to your project’s timeline, report progress, review dependencies, deadlines and much more. The map view is ideal for project managers and other stakeholders who have the relevant permissions and access level to make adjustments to assignments and impact overall project timetables.

What’s new in Project Map?

The project timeline and workstreams are pretty much identical to the way they were under the previous interface. The biggest change is the new toolbar, allowing an improved and more intuitive navigation experience. Similar to the Portfolio view, use the middle dropdown to toggle between ‘Map’ to ‘List’ or ‘Board’ views.

Ideally, planning your project will make more sense over the project map (timeline) , while execution on the other hand can be more intuitive when operated over a list of assignments.

Viewing a project list of tasks both in List and Board modes, allows you to create Filters and Saved Views. These will not be applicable in Map mode.

Add filters and choose the information you would like to see. Once you are satisfied with the result, you can click to ‘Save as’ so that your filter criteria will be kept for fast access whenever you need to use this information again.

Important! In order to personalize the information of a single project timeline in Map mode, click the ‘eye’ icon and select ‘Dynamic View’. The Filter option is not applicable.

The New Toolbar for your advanced features is here

This image has an empty alt attribute; its file name is xQYMh5fKufhPPBB7GVRN8Krwvq3rb7aY6jJ7l56wKVdFx6T8_b_K232tthiPthPJkE9ROZqd03tS1JodjipUnnAdSb0REe8iHvCf-tuqnP6VDCUaCdxohbzdkaU2kdMS__wbW7SS=s1600

How to create a new project

From the top right corner, click the ‘Plus’ icon to add a new project from scratch or from an existing template. When in Map mode, this is where you’ll also be able to add a portfolio milestone to the portfolio timeline.

ProTip: To turn an existing project into a template, switch to either ‘Card’ / ‘Board’ / ‘List’ mode  and select ‘Create template’ from the project menu (right click the project or click the 3 dots)

Filters and Saved Views – Portfolio Page:

Each one of the four display modes enables filtering and sorting of the project information. Activating a filter will be reflected across all views so you can create a filter while viewing the ‘List’ mode, then switch over to ‘Map’ mode to display the filtered projects over the timeline.

Save your selected filters to easily access the same list of projects later on. You can also add a ‘Star’ to this newly saved view by clicking the star at the top of the page, and add it to your “Favorites” list.

Favorites is a brand new area in Proggio! Making its day view with the release of the new user interface. As the name implies, the Favorites section allows you to save anything that you find important on a daily basis so you can find it (even quicker) all in one place. Favorites can include a specific Project, a saved list, a dashboard, a dynamic view and more.

New Portfolio Menu Options:

Previously the ‘View’ menu, is now transformed to an ‘eye’ icon on the tools bar allowing you to choose the type of information to display on the portfolio level.

Show connectors: Will show or hide cross project links. Read more about creating cross project links.

Show milestones: Will show or hide portfolio level milestones. Read more about project milestones.

Show Sub-projects: Will show or hide active sub projects on your project portfolio timeline. A sub-project will always show up below it’s parent project. Read more about sub-projects.

Milestone view: Is the default portfolio view showing your project’s milestone phases. This is a recommended view when reviewing high level projects status and progress.

Dynamic view: An advanced feature used for portfolio management allowing you to merge selected areas (Workstreams) from multiple project timelines into one incorporated and detailed project plan. Read more about how to utilize the Dynamic view in your workspace.

View options – Default / Cosy / Compact: Adjust the portfolio view to your preferred density.

Previously ‘Tools’ menu, transformed to a screwdriver and ratchet icon on the tools bar allowing you access to a few of Proggio’s advanced project management tools.

Coordination plan: This will generate an output table of all existing cross project links across your portfolio. This feature can be highly valuable when managing action items for overcoming dependencies across projects. Read more about it here.

Risk management plan: An advanced feature that lets you generate an output of all risk related activities and tasks across your portfolio and allows you to manage a detailed and actionable risk and mitigation plan. Read more about it here.

Basic functions – Undo / Redo: Applicable throughout an entire session.

Invite members to your workspace or share your project portfolio with other stakeholders.

Welcome to Proggio new UI

Managing your Project Portfolio has just become much smoother using the new UI. Logging into Proggio, you will notice that your normal ‘All Projects’ area is transformed into a hybrid new look operated by a new and improved tools bar.

Scroll through your saved project lists or create new views using a defined set of filters, to easily access a predefined set of projects whenever you need to review, present or execute projects.

Switch between view modes for high level management of your project portfolio according to your personal preference or required level of information.
Map: Will display your projects over a timeline, highlighting each project’s milestones, health indication, and scope of duration.

Cards: (Previously ‘Tiles’) Will display your active projects along with basic project info such as it’s name and project owner, project tag, rank and workflow stage.
ProTip: Switch to ‘Cards’ view to access your workspace templates, Archived projects and sub projects.

Kanban: Will display your active projects on their relative lifecycle stage along with basic project info such as it’s name and project owner, rank, tag and project priority.

List: Displaying all your active projects in a spreadsheet-like view, allowing you to add additional project metadata with additional columns. This is typically used for high level project decision making such as prioritizing against your business drivers.

Zoom in/out to display the Project Portfolio timeline in different views. Click the calendar day to align on the current day or click the calendar with the arrows to automatically center on the entire portfolio. 

Use this drop down menu to automatically zoom in and out to view the portfolio timeline in different scopes.